
<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">

	<head>

		<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<title>70,000 Memcached Servers Can Be Hacked Using Eight-Month-Old Flaws - The New Stack</title>
		<link rel="profile" href="//gmpg.org/xfn/11">
		<link rel="pingback" href="https://thenewstack.io/xmlrpc.php">
		<link rel="icon" href="https://thenewstack.io/favicon.ico" type="image/x-icon" />
		<link rel="shortcut icon" href="https://thenewstack.io/favicon.ico" type="image/x-icon" />
		<link href='https://fonts.googleapis.com/css?family=Open+Sans:400,700,700italic,600,600italic,400italic,300italic,300,800,800italic' rel='stylesheet' type='text/css'>
		<link href="https://fonts.googleapis.com/css?family=Merriweather:300,300i,400,400i,700,700i" rel="stylesheet">
		<link href="https://fonts.googleapis.com/css?family=Merriweather+Sans" rel="stylesheet">

		
<!-- This site is optimized with the Yoast SEO plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/" />
<link rel="publisher" href="https://plus.google.com/u/0/100040585732637649813"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="70,000 Memcached Servers Can Be Hacked Using Eight-Month-Old Flaws - The New Stack" />
<meta property="og:description" content="Eight months after three critical vulnerabilities were fixed in the memcached open source caching software, there are over 70,000 caching servers directly exposed on the internet that have yet to be patched. Hackers could execute malicious code on them or steal potentially sensitive data from their caches, security researchers warn. Memcached is a software package &hellip;" />
<meta property="og:url" content="https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/" />
<meta property="og:site_name" content="The New Stack" />
<meta property="article:publisher" content="https://www.facebook.com/thenewstack" />
<meta property="article:tag" content="authentication" />
<meta property="article:tag" content="cisco" />
<meta property="article:tag" content="CVE-2016-8704" />
<meta property="article:tag" content="CVE-2016-8705" />
<meta property="article:tag" content="CVE-2016-8706" />
<meta property="article:tag" content="Development" />
<meta property="article:tag" content="memcache" />
<meta property="article:tag" content="memcached" />
<meta property="article:tag" content="remote code execution" />
<meta property="article:tag" content="Security" />
<meta property="article:tag" content="Simple Authentication and Security Layer" />
<meta property="article:tag" content="Talos" />
<meta property="article:tag" content="Vulnerabilities" />
<meta property="article:tag" content="vulnerability" />
<meta property="article:tag" content="Web Development" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2017-07-24T02:00:22-07:00" />
<meta property="article:modified_time" content="2017-07-21T12:54:09-07:00" />
<meta property="og:updated_time" content="2017-07-21T12:54:09-07:00" />
<meta property="og:image" content="https://cdn.thenewstack.io/media/2017/07/261d7153-business-841174_640.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="429" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Eight months after three critical vulnerabilities were fixed in the memcached open source caching software, there are over 70,000 caching servers directly exposed on the internet that have yet to be patched. Hackers could execute malicious code on them or steal potentially sensitive data from their caches, security researchers warn. Memcached is a software package [&hellip;]" />
<meta name="twitter:title" content="70,000 Memcached Servers Can Be Hacked Using Eight-Month-Old Flaws - The New Stack" />
<meta name="twitter:site" content="@thenewstack" />
<meta name="twitter:image" content="https://cdn.thenewstack.io/media/2017/07/261d7153-business-841174_640.jpg" />
<meta name="twitter:creator" content="@lconstantin" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//cdn.thenewstack.io' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The New Stack &raquo; Feed" href="https://thenewstack.io/feed/" />
<link rel="alternate" type="application/rss+xml" title="The New Stack &raquo; Comments Feed" href="https://thenewstack.io/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/thenewstack.io\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='stripe-checkout-button-css'  href='https://checkout.stripe.com/v3/checkout/button.css?ver=2.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='pikaday-css'  href='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/css/vendor/pikaday.min.css?ver=2.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='stripe-checkout-pro-public-css'  href='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/css/public-pro.min.css?ver=2.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='cforms2-css'  href='https://thenewstack.io/wp-content/plugins/cforms2/styling/cforms.css?ver=14.13.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://thenewstack.io/wp-includes/css/dashicons.min.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='ssbaFont-css'  href='//fonts.googleapis.com/css?family=Indie+Flower&#038;ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='wprssmi_template_styles-css'  href='https://thenewstack.io/wp-content/plugins/wp-rss-multi-importer/templates/templates.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='thenewstack-style-css'  href='https://thenewstack.io/wp-content/themes/thenewstack/style.css?ver=1499304267' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-tables-style-css'  href='https://thenewstack.io/wp-content/themes/thenewstack/inc/responsive-tables/responsive-tables.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='Fontawesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.2.0/css/font-awesome.min.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-dark-css'  href='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/dark/style.css?ver=2.10.0' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-default-css'  href='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/default/style.css?ver=2.10.0' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-ebook-sponsors-css'  href='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/ebook-sponsors/style.css?ver=2.10.0' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-standard-css'  href='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/standard/style.css?ver=2.10.0' type='text/css' media='all' />
<link rel='stylesheet' id='cyclone-template-style-thumbnails-css'  href='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/thumbnails/style.css?ver=2.10.0' type='text/css' media='all' />
<script type='text/javascript' src='https://thenewstack.io/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cforms2_ajax = {"url":"https:\/\/thenewstack.io\/wp-admin\/admin-ajax.php","nonces":{"submitcform":"bb57d47e9e"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cforms2/js/cforms.js?ver=14.13.3'></script>
<script id='st_insights_js' type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/validator/4.0.5/validator.min.js?ver=4.8'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/jquery.transit/0.9.12/jquery.transit.min.js?ver=4.8'></script>
<script type='text/javascript' src='//cdn.thenewstack.io/static/js/jquery.mobile-events.min.js?ver=4.8'></script>
<script type='text/javascript' src='//cdn.thenewstack.io/static/js/date-format.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='https://thenewstack.io/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://thenewstack.io/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://thenewstack.io/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8" />
<link rel='shortlink' href='https://thenewstack.io/?p=2728110' />
<link rel="alternate" type="application/json+oembed" href="https://thenewstack.io/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthenewstack.io%2F70000-memcached-servers-can-hacked-using-eight-month-old-flaws%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://thenewstack.io/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthenewstack.io%2F70000-memcached-servers-can-hacked-using-eight-month-old-flaws%2F&#038;format=xml" />
<script type="text/javascript">
	window._se_plugin_version = '8.1.9';
</script>
<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">	.ssba {
									
									
									
									
								}
								.ssba img
								{
									width: 35px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									border:0;
									background: none;
									font-family: Indie Flower;
									font-size: 	20px;
									
									font-weight: bold;
								}
								</style><meta name="twitter:widgets:link-color" content="#000000"><meta name="twitter:widgets:border-color" content="#000000"><meta name="twitter:partner" content="tfwp">
<meta name="twitter:card" content="summary"><meta name="twitter:title" content="70,000 Memcached Servers Can Be Hacked Using Eight-Month-Old Flaws"><meta name="twitter:site" content="@thenewstack"><meta name="twitter:description" content="Eight months after three critical vulnerabilities were fixed in the memcached open source caching software, there are over 70,000 caching servers directly exposed on the internet that have yet to be patched. Hackers could execute malicious code on them or steal potentially sensitive data from their caches, security researchers warn. Memcached is a software package&hellip;"><meta name="twitter:image" content="https://cdn.thenewstack.io/media/2017/07/261d7153-business-841174_640.jpg"><meta name="twitter:creator" content="@lconstantin">

		<script type="text/javascript">

			/// GA Install
			var analyticsFileTypes = [''];
		    var analyticsSnippet = 'disabled';
		    var analyticsEventTracking = 'enabled';

			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

			var host = window.location.hostname;

			if (host === 'dev.thenewstack.io') {
				ga('create', 'UA-20797087-4', 'auto'); /// Dev
			}else{
				ga('create', 'UA-50424056-1', 'auto'); /// Live
			}

						ga('set','dimension1','Lucian Constantin');
			
			
			ga('send','pageview');

		</script>

		<script type="text/javascript">
			/// Heap Install
			window.heap=window.heap||[],heap.load=function(e,t){window.heap.appid=e,window.heap.config=t=t||{};
			var n=t.forceSSL||"https:"===document.location.protocol,a=document.createElement("script");
			a.type="text/javascript",a.async=!0,a.src=(n?"https:":"http:")+"//cdn.heapanalytics.com/js/heap-"+e+".js";
			var o=document.getElementsByTagName("script")[0];o.parentNode.insertBefore(a,o);
			for(var r=function(e){return function(){heap.push([e].concat(Array.prototype.slice.call(arguments,0)))}},
			p=["clearEventProperties","identify","setEventProperties","track","unsetEventProperty"],
			c=0;c<p.length;c++)heap[p[c]]=r(p[c])};

			heap.load("609441517");

		</script>

		<!-- Facebook Pixel Code -->
		<script>
			!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
			n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
			document,'script','https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '1824226617806384');
			fbq('track', "PageView");</script>
			<noscript><img height="1" width="1" style="display:none"
			src="https://www.facebook.com/tr?id=1824226617806384&ev=PageView&noscript=1"
		/></noscript>
		<!-- End Facebook Pixel Code -->

	</head>

	<body class="post-template-default single single-post postid-2728110 single-format-standard group-blog">


		
		<div id="navsearchform" class="search-pane ">
							<div class="menu-close"></div>
				<h4>SEARCH FOR</h4>
				<form role="search" method="get" class="ns-search-form" action="https://thenewstack.io">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="ns-search" placeholder="Search …" value="" name="s" title="Search for:">
	</label>
	<input type="submit" class="ns-search-submit" value="Search">
</form>					</div>

		<nav id="responsive-menu">

			<div class="menu-close">x</div>

			<h4>Content</h4>
			<div class="menu-primary-menu-container"><ul id="resp-primary" class="menu"><li id="menu-item-1937460" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1937460"><h5 class="reversedlinks"><a href="https://thenewstack.io/category/analysis/">Analysis</a></h5></li>
<li id="menu-item-1426855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1426855"><h5 class="reversedlinks"><a href="/ebooks/">Ebooks</a></h5></li>
<li id="menu-item-28271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28271"><h5 class="reversedlinks"><a href="https://thenewstack.io/events/">Events</a></h5></li>
<li id="menu-item-880403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880403"><h5 class="reversedlinks"><a href="https://thenewstack.io/podcasts/">Podcasts</a></h5></li>
<li id="menu-item-1937807" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1937807"><h5 class="reversedlinks"><a href="https://thenewstack.io/category/research/">Research</a></h5></li>
<li id="menu-item-1937461" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1937461"><h5 class="reversedlinks"><a href="#">Topic Hubs <span class="dashicons dashicons-arrow-down"></span></a></h5>
<ul  class="sub-menu">
	<li id="menu-item-1937462" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937462"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/architecture/">Architecture</a></h5></li>
	<li id="menu-item-1937475" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937475"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/data/">Data</a></h5></li>
	<li id="menu-item-1937463" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937463"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/development/">Development</a></h5></li>
	<li id="menu-item-1937464" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937464"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/diy/">Do-It-Yourself</a></h5></li>
	<li id="menu-item-1937465" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937465"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/operations/">Operations</a></h5></li>
	<li id="menu-item-1937476" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937476"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/security/">Security</a></h5></li>
	<li id="menu-item-1937466" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937466"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/tech-culture/">Tech Culture</a></h5></li>
</ul>
</li>
<li id="menu-item-1937467" class="primary-nav-last-option menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1937467"><h5 class="reversedlinks"><a href="#">Ecosystems <span class="dashicons dashicons-arrow-down"></span></a></h5>
<ul  class="sub-menu">
	<li id="menu-item-1937468" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937468"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/artificial-intelligence/">Artificial Intelligence</a></h5></li>
	<li id="menu-item-1937469" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937469"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/cloud/">Cloud</a></h5></li>
	<li id="menu-item-1937470" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937470"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/containers/">Containers</a></h5></li>
	<li id="menu-item-1937471" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937471"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/kubernetes/">Kubernetes</a></h5></li>
	<li id="menu-item-1937472" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937472"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/microservices/">Microservices</a></h5></li>
	<li id="menu-item-1937473" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937473"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/node-js/">Node.js</a></h5></li>
	<li id="menu-item-1937474" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937474"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/serverless/">Serverless</a></h5></li>
</ul>
</li>
<li id="menu-item-599" class="menu-bar menu-item menu-item-type-custom menu-item-object-custom menu-item-599"><h5 class="reversedlinks"><a href="#">mobile-menu-icon</a></h5></li>
<li id="menu-item-598" class="navsearch menu-item menu-item-type-custom menu-item-object-custom menu-item-598"><h5 class="reversedlinks"><a href="#">search-icon</a></h5></li>
</ul></div>
			<h4>Topic Hubs</h4>
			<div class="menu-topic-hubs-container"><ul id="resp-topic-hubs" class="menu"><li id="menu-item-1937477" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937477"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/architecture/">Architecture</a></h5></li>
<li id="menu-item-1937478" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937478"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/data/">Data</a></h5></li>
<li id="menu-item-1937479" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937479"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/development/">Development</a></h5></li>
<li id="menu-item-1937480" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937480"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/diy/">Do-It-Yourself</a></h5></li>
<li id="menu-item-1937481" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937481"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/operations/">Operations</a></h5></li>
<li id="menu-item-1937482" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937482"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/security/">Security</a></h5></li>
<li id="menu-item-1937483" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937483"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/tech-culture/">Tech Culture</a></h5></li>
</ul></div>
			<h4>Ecosystems</h4>
			<div class="menu-ecosystems-container"><ul id="resp-ecosystems" class="menu"><li id="menu-item-1937484" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937484"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/artificial-intelligence/">AI</a></h5></li>
<li id="menu-item-1937485" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937485"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/cloud/">Cloud</a></h5></li>
<li id="menu-item-1937486" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937486"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/containers/">Containers</a></h5></li>
<li id="menu-item-1937487" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937487"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/kubernetes/">Kubernetes</a></h5></li>
<li id="menu-item-1937488" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937488"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/microservices/">Microservices</a></h5></li>
<li id="menu-item-1937489" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937489"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/node-js/">Node.js</a></h5></li>
<li id="menu-item-1937490" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937490"><h5 class="reversedlinks"><a href="https://thenewstack.io/tag/serverless/">Serverless</a></h5></li>
</ul></div>
			<h4>The New Stack</h4>
			<div class="menu-the-new-stack-container"><ul id="resp-ancillary" class="menu"><li id="menu-item-600" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-600"><h5 class="reversedlinks"><a href="https://thenewstack.io/about-2/">About</a></h5></li>
<li id="menu-item-601" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-601"><h5 class="reversedlinks"><a href="https://thenewstack.io/contact/">Contact</a></h5></li>
<li id="menu-item-602" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-602"><h5 class="reversedlinks"><a href="https://thenewstack.io/sponsors/">Sponsors</a></h5></li>
<li id="menu-item-764345" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764345"><h5 class="reversedlinks"><a href="https://thenewstack.io/privacy-policy/">Privacy Policy</a></h5></li>
</ul></div>
			<h4>Follow</h4>
			<div class="menu-follow-container"><ul id="resp-follow" class="menu"><li id="menu-item-583" class="twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-583"><h5 class="reversedlinks"><a target="_blank" href="https://twitter.com/thenewstack">Twitter</a></h5></li>
<li id="menu-item-584" class="facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-584"><h5 class="reversedlinks"><a target="_blank" href="https://www.facebook.com/thenewstack">Facebook</a></h5></li>
<li id="menu-item-224124" class="youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-224124"><h5 class="reversedlinks"><a target="_blank" href="https://www.youtube.com/channel/UCWea_KfCnTMD39uQuA5TKOQ">YouTube</a></h5></li>
<li id="menu-item-880401" class="soundcloud menu-item menu-item-type-custom menu-item-object-custom menu-item-880401"><h5 class="reversedlinks"><a target="_blank" href="https://soundcloud.com/search?q=the%20new%20stack">Soundcloud</a></h5></li>
<li id="menu-item-586" class="linkedin menu-item menu-item-type-custom menu-item-object-custom menu-item-586"><h5 class="reversedlinks"><a target="_blank" href="https://www.linkedin.com/company/6611720">LinkedIn</a></h5></li>
<li id="menu-item-880402" class="slideshare menu-item menu-item-type-custom menu-item-object-custom menu-item-880402"><h5 class="reversedlinks"><a target="_blank" href="http://www.slideshare.net/TheNewStack">Slideshare</a></h5></li>
<li id="menu-item-1767" class="rss menu-item menu-item-type-custom menu-item-object-custom menu-item-1767"><h5 class="reversedlinks"><a target="_blank" href="http://thenewstack.io/rss-feeds">RSS</a></h5></li>
</ul></div>
		</nav>

		<!--div id="page" class="hfeed site"-->

		<div class="overlay"></div>

		<div class="top-bar-wrap">
			<div class="top-bar">

				<nav id="ancillary" class="ancillary-navigation" role="navigation">
					<div class="menu-the-new-stack-container"><ul id="top-ancillary" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-600"><h5 class="reversedlinks"><a href="https://thenewstack.io/about-2/">About</a></h5></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-601"><h5 class="reversedlinks"><a href="https://thenewstack.io/contact/">Contact</a></h5></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-602"><h5 class="reversedlinks"><a href="https://thenewstack.io/sponsors/">Sponsors</a></h5></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764345"><h5 class="reversedlinks"><a href="https://thenewstack.io/privacy-policy/">Privacy Policy</a></h5></li>
</ul></div><div class="menu-follow-container"><ul id="top-follow" class="menu"><li class="twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-583"><a target="_blank" href="https://twitter.com/thenewstack">Twitter</a></li>
<li class="facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-584"><a target="_blank" href="https://www.facebook.com/thenewstack">Facebook</a></li>
<li class="youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-224124"><a target="_blank" href="https://www.youtube.com/channel/UCWea_KfCnTMD39uQuA5TKOQ">YouTube</a></li>
<li class="soundcloud menu-item menu-item-type-custom menu-item-object-custom menu-item-880401"><a target="_blank" href="https://soundcloud.com/search?q=the%20new%20stack">Soundcloud</a></li>
<li class="linkedin menu-item menu-item-type-custom menu-item-object-custom menu-item-586"><a target="_blank" href="https://www.linkedin.com/company/6611720">LinkedIn</a></li>
<li class="slideshare menu-item menu-item-type-custom menu-item-object-custom menu-item-880402"><a target="_blank" href="http://www.slideshare.net/TheNewStack">Slideshare</a></li>
<li class="rss menu-item menu-item-type-custom menu-item-object-custom menu-item-1767"><a target="_blank" href="http://thenewstack.io/rss-feeds">RSS</a></li>
</ul></div>				</nav>

			</div>
		</div>

		<div class="nav-bar clearfix">

			<header id="masthead" class="site-header" role="banner">

				<a class="site-branding" href="https://thenewstack.io/" rel="home">
					<img id="TNS-Logo" src="https://cdn.thenewstack.io/static/img/The-New-Stack-Logo.svg">
				</a>

				<nav id="site-navigation" class="main-navigation" role="navigation">

					<a class="skip-link screen-reader-text" href="#content">
						Skip to content					</a>

					<div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1937460"><h5 class="links"><a href="https://thenewstack.io/category/analysis/">Analysis</a></h5></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1426855"><h5 class="links"><a href="/ebooks/">Ebooks</a></h5></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28271"><h5 class="links"><a href="https://thenewstack.io/events/">Events</a></h5></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880403"><h5 class="links"><a href="https://thenewstack.io/podcasts/">Podcasts</a></h5></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1937807"><h5 class="links"><a href="https://thenewstack.io/category/research/">Research</a></h5></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1937461"><h5 class="links"><a href="#">Topic Hubs <span class="dashicons dashicons-arrow-down"></span></a></h5>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937462"><h5 class="links"><a href="https://thenewstack.io/tag/architecture/">Architecture</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937475"><h5 class="links"><a href="https://thenewstack.io/tag/data/">Data</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937463"><h5 class="links"><a href="https://thenewstack.io/tag/development/">Development</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937464"><h5 class="links"><a href="https://thenewstack.io/tag/diy/">Do-It-Yourself</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937465"><h5 class="links"><a href="https://thenewstack.io/tag/operations/">Operations</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937476"><h5 class="links"><a href="https://thenewstack.io/tag/security/">Security</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937466"><h5 class="links"><a href="https://thenewstack.io/tag/tech-culture/">Tech Culture</a></h5></li>
</ul>
</li>
<li class="primary-nav-last-option menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1937467"><h5 class="links"><a href="#">Ecosystems <span class="dashicons dashicons-arrow-down"></span></a></h5>
<ul  class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937468"><h5 class="links"><a href="https://thenewstack.io/tag/artificial-intelligence/">Artificial Intelligence</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937469"><h5 class="links"><a href="https://thenewstack.io/tag/cloud/">Cloud</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937470"><h5 class="links"><a href="https://thenewstack.io/tag/containers/">Containers</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937471"><h5 class="links"><a href="https://thenewstack.io/tag/kubernetes/">Kubernetes</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937472"><h5 class="links"><a href="https://thenewstack.io/tag/microservices/">Microservices</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937473"><h5 class="links"><a href="https://thenewstack.io/tag/node-js/">Node.js</a></h5></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937474"><h5 class="links"><a href="https://thenewstack.io/tag/serverless/">Serverless</a></h5></li>
</ul>
</li>
<li class="menu-bar menu-item menu-item-type-custom menu-item-object-custom menu-item-599"><h5 class="links"><a href="#">mobile-menu-icon</a></h5></li>
<li class="navsearch menu-item menu-item-type-custom menu-item-object-custom menu-item-598"><h5 class="links"><a href="#">search-icon</a></h5></li>
</ul></div>
				</nav>

			</header>

		</div>

	<div id="primary" class="content-area">

		<main id="main" class="site-main" role="main">

		
<article id="2728110" class="post-2728110 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-technology category-top_story tag-authentication tag-cisco tag-cve-2016-8704 tag-cve-2016-8705 tag-cve-2016-8706 tag-development tag-memcache tag-memcached tag-remote-code-execution tag-security tag-simple-authentication-and-security-layer tag-talos tag-vulnerabilities tag-vulnerability tag-web-development region-global">

	<header class="entry-header">

		<h4>
	        <a href="https://thenewstack.io/category/news/" alt="View all posts in News">News</a> / <a href="https://thenewstack.io/category/technology/" alt="View all posts in Technology">Technology</a> / <a href="https://thenewstack.io/category/top_story/" alt="View all posts in Top Stories">Top Stories</a> / <a href="https://thenewstack.io/region/global/" rel="tag">Global</a> 	    </h4>

		<h1>70,000 Memcached Servers Can Be Hacked Using Eight-Month-Old Flaws</h1>

		<h4 class="timestamp">
		24 Jul 2017 2:00am,

		by <span class="links">
			<a href="https://thenewstack.io/author/lucian/" title="Posts by Lucian Constantin" class="author url fn" rel="author">Lucian Constantin</a>	 		</span>

	    </h4>

	</header>


	<div class="postfeat">
		<img width="640" height="429" src="https://cdn.thenewstack.io/media/2017/07/261d7153-business-841174_640.jpg" class="attachment-large size-large wp-post-image wp-stateless-item" alt="" data-image-size="large" data-stateless-media-bucket="cdn.thenewstack.io" data-stateless-media-name="media/2017/07/261d7153-business-841174_640.jpg" />	</div>


	<div class="resp-container">

		<div class="postshare">

			<div class="social-header">

				<!-- Simple Share Buttons Adder (6.3.6) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left"><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/&amp;text=70%2C000+Memcached+Servers+Can+Be+Hacked+Using+Eight-Month-Old+Flaws+"  target="_blank" ><img src="https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/"  target="_blank" ><img src="https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/"  target="_blank" ><img src="https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/linkedin.png" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /></a></div></div>
				<div class="commentcloud">

					
	                <a id="showbox" href="//thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/#disqus_thread">+</a>

	        	</div>

			</div>

		</div>


		<div class="entry-content">

			
			<div class="post-content">
				<p>Eight months after three critical vulnerabilities were fixed in the memcached open source caching software, there are over 70,000 caching servers directly exposed on the internet that have yet to be patched. Hackers could execute malicious code on them or steal potentially sensitive data from their caches, security researchers warn.</p>
<p><a href="https://memcached.org/" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">Memcached</a> is a software package that implements a high performance caching server for storing chunks of data obtained from database and API calls in RAM. This helps speed up dynamic web applications, making it well suited for large websites and big-data projects.</p>
<p>While memcached is not a database replacement, the data it stores in RAM can include user sessions and other sensitive information from database queries. As such, the server was not designed to be directly exposed to untrusted environments like the internet, even though some of the more recent versions support basic authentication.</p>
<p>Back in October, the memcached developers fixed three remote code execution vulnerabilities (<a href="https://www.talosintelligence.com/reports/TALOS-2016-0219/" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">CVE-2016-8704</a>, <a href="https://www.talosintelligence.com/reports/TALOS-2016-0220/" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">CVE-2016-8705</a> and <a href="https://www.talosintelligence.com/reports/TALOS-2016-0221/" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">CVE-2016-8706</a>) that were found and reported by security researchers from <a href="https://www.talosintelligence.com/" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">Cisco Systems&#8217; Talos division</a>. All of these flaws affected memcached&#8217;s binary protocol for storing and retrieving data and one of them was in the <a href="https://tools.ietf.org/html/rfc4422" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">Simple Authentication and Security Layer </a>(SASL) implementation.</p>
<p>Throughout December and January several groups of attackers wiped data from tens of thousands of publicly exposed databases including MongoDB, CouchDB, Hadoop and Elasticsearch clusters. In many cases they asked server administrators for money to return the data, but there was no evidence they actually copied it.</p>
<p>The Talos researchers thought that memcached servers might be the next target, especially giving the flaws they had identified a few months earlier, so in February they decided to run a series of internet scans to determine the potential attack surface.</p>
<p>The scan results revealed that around 108,000 memcached servers were directly exposed to the internet and only 24,000 of them required authentication. The fact that so many servers were publicly accessible without authentication was bad enough, but when they also tested for the presence of the three vulnerabilities, they found that only 200 servers requiring authentication actually had the October patches deployed. All the rest were open to hacking through the SASL vulnerability.</p>
<p>Overall, 85,000 or around 80 percent of all memcached servers exposed to the internet lacked the security fixes for the three critical flaws announced in October.</p>
<p>Troubled by the poor patch adoption rate, the Talos researchers decided to run whois queries on the IP addresses of all of those servers and send notification emails to their owners.</p>
<p>Earlier this month the researchers decided to redo their scans. They found that there are still 106,000 memcached servers exposed to the internet, although 28,500 have different IP addresses than the ones found in February.</p>
<p>Of these 106,000 servers, 73,400 or around 70 percent continue to be vulnerable to the three exploits patched in October. Over 18,000 of the identified servers require authentication and 99 percent of those continue to have the SASL vulnerability.</p>
<p>Even after sending tens of thousands of notification emails, the patch adoption rate improved by only 10 percent in six months.</p>
<p>&#8220;The severity of these types of vulnerabilities cannot be understated,&#8221; the Talos researchers said Monday in a <a href="http://blog.talosintelligence.com/2017/07/memcached-patch-failure.html" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">blog post</a>. &#8220;These vulnerabilities potentially affect a platform that is deployed across the internet by small and large enterprises alike. With the recent spate of worm attacks leveraging vulnerabilities this should be a red flag for administrators around the world. If left unaddressed the vulnerabilities could be leveraged to impact organizations globally and impact business severely.&#8221;</p>
<p>The conclusions of this exercise suggest that many web application owners do a poor job of safeguarding their users&#8217; data. First, a surprisingly large number of memcached servers are directly exposed to the internet and the majority of them do not use authentication. The data cached on these servers is at risk even without the presence of any vulnerabilities.</p>
<p>Second, even when critical vulnerabilities that could be used to completely compromise servers are patched, many server administrators don&#8217;t apply the security fixes in a timely manner, if ever.</p>
<p>Under these circumstances, seeing large scale attacks against memcached servers like those that targeted MongoDB databases would not be surprising.</p>
<p class="attribution">Feature image <a href="https://pixabay.com/en/business-model-woman-message-girl-841174/" class="ext-link" rel="external nofollow" onclick="this.target=&#039;_blank&#039;;">via</a> Pixabay.</p>
			</div>

			
		</div>


		<footer class="entry-footer">

			<div class="newtags"><a href="https://thenewstack.io/tag/authentication/" class="taglinks">authentication</a><a href="https://thenewstack.io/tag/cisco/" class="taglinks">cisco</a><a href="https://thenewstack.io/tag/cve-2016-8704/" class="taglinks">CVE-2016-8704</a><a href="https://thenewstack.io/tag/cve-2016-8705/" class="taglinks">CVE-2016-8705</a><a href="https://thenewstack.io/tag/cve-2016-8706/" class="taglinks">CVE-2016-8706</a><a href="https://thenewstack.io/tag/development/" class="taglinks">Development</a><a href="https://thenewstack.io/tag/memcache/" class="taglinks">memcache</a><a href="https://thenewstack.io/tag/memcached/" class="taglinks">memcached</a><a href="https://thenewstack.io/tag/remote-code-execution/" class="taglinks">remote code execution</a><a href="https://thenewstack.io/tag/security/" class="taglinks">Security</a><a href="https://thenewstack.io/tag/simple-authentication-and-security-layer/" class="taglinks">Simple Authentication and Security Layer</a><a href="https://thenewstack.io/tag/talos/" class="taglinks">Talos</a><a href="https://thenewstack.io/tag/vulnerabilities/" class="taglinks">Vulnerabilities</a><a href="https://thenewstack.io/tag/vulnerability/" class="taglinks">vulnerability</a><a href="https://thenewstack.io/tag/web-development/" class="taglinks">Web Development</a></div>

			<div class="social-footer">
				<div class="postshare">
					<div class="social-header">
						<!-- Simple Share Buttons Adder (6.3.6) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left"><a data-site="" class="ssba_twitter_share" href="http://twitter.com/share?url=https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/&amp;text=70%2C000+Memcached+Servers+Can+Be+Hacked+Using+Eight-Month-Old+Flaws+"  target="_blank" ><img src="https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/twitter.png" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" /></a><a data-site="" class="ssba_facebook_share" href="http://www.facebook.com/sharer.php?u=https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/"  target="_blank" ><img src="https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/facebook.png" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" /></a><a data-site="linkedin" class="ssba_linkedin_share ssba_share_link" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/"  target="_blank" ><img src="https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/buttons/somacro/linkedin.png" title="LinkedIn" class="ssba ssba-img" alt="Share on LinkedIn" /></a></div></div>						<div class="commentcloud">

							
	            			<a id="showbox" href="//thenewstack.io/70000-memcached-servers-can-hacked-using-eight-month-old-flaws/#disqus_thread" >+</a>

	    				</div>
					</div>
				</div>
			</div>

		</footer>


	</div>

</article>

</main>

</div>





<script>
	
	jQuery(document).ready(function($) {
		
		$('.newsletter-sign-up-button').on('click', function(event) {
		
			var email = $('.newsletter-sign-up-input').val();
			
			if (!email) return alert('You must enter a valid email.');
			if (!validator.isEmail(email)) return alert('You must enter a valid email.');
			
			$.post('/newsletter-sign-up-submit', {
				email : email
			}, function(result) {
			
				if (result === 'ERROR') return alert('An error occurred, please try again momentarily.');
				
				$('.newsletter-sign-up-input').val('');
				alert('Thank you for subscribing.');
				
			});
		
		});
		
	});
	
</script>


<div class="newsletter-sign-up">
	<div class="newsletter-sign-up-block">
		
		<img src="https://cdn.thenewstack.io/static/img/The-New-Stack-Updates-Logo.svg"><BR>
		
		<H3>A digest of the week’s most important stories & analyses.</H3>
		
		<div class="newsletter-sign-up-form">
			<input class="newsletter-sign-up-input" type="email" placeholder="Email Address"><button class="newsletter-sign-up-button">Subscribe</button><BR>
			<div class="newsletter-sign-up-no-spam">We don’t sell or share your email. Occasionally, we send updates and useful info.</div>
		</div>
	
	</div>
</div>





<div class="related-posts">
	<div class="related-posts-wrapper">

		<div class="sectionheader">Related Stories</div>

		
<div class="normalstory-box">
	
	<div class="commentcloud">
		<h5 class="links">
	        	        <a href="//thenewstack.io/take-advantage-new-twilio-apis-cover-just-telephony/#disqus_thread">+</a>
	    </h5>
	</div>
	
	<a href="https://thenewstack.io/take-advantage-new-twilio-apis-cover-just-telephony/" class="athumbnail">
		
			    
		<div class="normalstory-overlay" style="display: none;">
			<img src="">
		</div>
		
		
		<img width="290" height="120" src="https://cdn.thenewstack.io/media/2017/07/e13aa15a-joshua-earle-234343-290x120.jpg" class="attachment-normal size-normal wp-post-image wp-stateless-item" alt="" data-image-size="normal" data-stateless-media-bucket="cdn.thenewstack.io" data-stateless-media-name="media/2017/07/e13aa15a-joshua-earle-234343.jpg" />		
	</a>

	<header class="title-row">
		
		<h4>
	        <a href="https://thenewstack.io/category/analysis/" alt="View all posts in Analysis">Analysis</a> / <a href="https://thenewstack.io/category/technology/" alt="View all posts in Technology">Technology</a> / <a href="https://thenewstack.io/category/top_story/" alt="View all posts in Top Stories">Top Stories</a> / <a href="https://thenewstack.io/region/global/" rel="tag">Global</a> / <a href="https://thenewstack.io/region/north-america/" rel="tag">North America</a> 	    </h4>
	
		<h2 class="small">
			<a href="https://thenewstack.io/take-advantage-new-twilio-apis-cover-just-telephony/">New Twilio APIs Can Help Developers with Authentication, Session Management, Data Synchronization</a>
		</h2>
		
		<h4 class="timestamp">1:00am,
	
		 by <span class="links">
	
				<a href="https://thenewstack.io/author/marybranscombe/" title="Posts by Mary Branscombe" class="author url fn" rel="author">Mary Branscombe</a>	
	        </span>
        
	</header>

</div>



<div class="normalstory-box">
	
	<div class="commentcloud">
		<h5 class="links">
	        	        <a href="//thenewstack.io/slack-brings-apps-front-center-api-update/#disqus_thread">+</a>
	    </h5>
	</div>
	
	<a href="https://thenewstack.io/slack-brings-apps-front-center-api-update/" class="athumbnail">
		
			    
		<div class="normalstory-overlay" style="display: none;">
			<img src="">
		</div>
		
		
		<img width="290" height="120" src="https://cdn.thenewstack.io/media/2017/07/71fe517f-slack-290x120.png" class="attachment-normal size-normal wp-post-image wp-stateless-item" alt="" data-image-size="normal" data-stateless-media-bucket="cdn.thenewstack.io" data-stateless-media-name="media/2017/07/71fe517f-slack.png" />		
	</a>

	<header class="title-row">
		
		<h4>
	        <a href="https://thenewstack.io/category/news/" alt="View all posts in News">News</a> / <a href="https://thenewstack.io/category/technology/" alt="View all posts in Technology">Technology</a> / <a href="https://thenewstack.io/category/top_story/" alt="View all posts in Top Stories">Top Stories</a>	    </h4>
	
		<h2 class="small">
			<a href="https://thenewstack.io/slack-brings-apps-front-center-api-update/">Slack Brings Apps Front and Center with API Update</a>
		</h2>
		
		<h4 class="timestamp">24 Jul 2017 6:00am,
	
		 by <span class="links">
	
				<a href="https://thenewstack.io/author/mike-melanson/" title="Posts by Mike Melanson" class="author url fn" rel="author">Mike Melanson</a>	
	        </span>
        
	</header>

</div>



	</div>
</div>

				<div class="comment-block">
					<div id="comments" class="comments-area">
						<div class="button-wrapper">
							<div class="showDisqus">View / Add Comments</div>
						</div>
		        		<div id="disqus_thread"></div>
					</div>
				</div>

		

			<div class="sponsored-feed">
				<div class="related-posts-wrapper rss-block">
				<div class="sectionheader">Sponsored Feed</div>
					<div class="singlerss-wrap"><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="http://www.vmwareblogs.com/article.jsp?id=4728900771119104" ><img src="https://cdn.thenewstack.io/media/2017/05/951da3dd-vmware@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="http://www.vmwareblogs.com/article.jsp?id=4728900771119104" >VMworld: 8 VMTN Community Opportunities You Don’t Want to Miss</a></div><span class="date">July 24, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.godaddy.com/garage/webpro/security/setting-two-factor-authentication-wordpress/" ><img src="https://cdn.thenewstack.io/media/2016/04/GoDaddy@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.godaddy.com/garage/webpro/security/setting-two-factor-authentication-wordpress/" >Setting up two-factor authentication for WordPress</a></div><span class="date">July 24, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://blog.chef.io/2017/07/24/chef-community-engineering-q2-update/" ><img src="https://cdn.thenewstack.io/media/2017/05/d217cf09-chef@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://blog.chef.io/2017/07/24/chef-community-engineering-q2-update/" >Chef Community Engineering – Q2 Update</a></div><span class="date">July 24, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="http://superuser.openstack.org/articles/tencent-openstack/" ><img src="https://cdn.thenewstack.io/media/2017/06/bded1ace-openstack@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="http://superuser.openstack.org/articles/tencent-openstack/" >How tech giant Tencent uses OpenStack</a></div><span class="date">July 23, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="http://blog.wercker.com/how-does-kubernetes-handle-load-balancing" ><img src="https://cdn.thenewstack.io/media/2016/10/wercker@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="http://blog.wercker.com/how-does-kubernetes-handle-load-balancing" >Kubernetes Internals: Load Balancing</a></div><span class="date">July 23, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://blog.openshift.com/kubernetes-deep-dive-api-server-part-2/" ><img src="https://cdn.thenewstack.io/media/2014/12/RedHat@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://blog.openshift.com/kubernetes-deep-dive-api-server-part-2/" >Kubernetes Deep Dive: API Server – Part 2</a></div><span class="date">July 21, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://blog.codeship.com/post-mortem-codeship-basic-platform-build-processing-incident/" ><img src="https://cdn.thenewstack.io/media/2017/04/3dc0848f-codeship@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://blog.codeship.com/post-mortem-codeship-basic-platform-build-processing-incident/" >Postmortem: Codeship Basic Platform Build Processing Incident</a></div><span class="date">July 21, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.cncf.io/blog/2017/07/20/ancestry-digging-past-new-technology/" ><img src="https://cdn.thenewstack.io/media/2016/08/CNCF@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.cncf.io/blog/2017/07/20/ancestry-digging-past-new-technology/" >Ancestry: Digging into the Past With New Technology</a></div><span class="date">July 20, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="http://www.apmdigest.com/apmacademy/why-you-should-bet-on-network-monitoring-software" ><img src="https://cdn.thenewstack.io/media/2017/04/6c31aa38-ca@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="http://www.apmdigest.com/apmacademy/why-you-should-bet-on-network-monitoring-software" >Why You Should Bet on Network Monitoring Software</a></div><span class="date">July 20, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.cloudfoundry.org/from-the-desk-of-the-executive-director-july-2017/" ><img src="https://cdn.thenewstack.io/media/2016/04/CloudFoundry@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.cloudfoundry.org/from-the-desk-of-the-executive-director-july-2017/" >From the Desk of the Executive Director – July 2017</a></div><span class="date">July 20, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.pagerduty.com/blog/pdsummit17/" ><img src="https://cdn.thenewstack.io/media/2017/04/042245f3-pagerduty@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.pagerduty.com/blog/pdsummit17/" >It’s Coming: PagerDuty Summit ‘17</a></div><span class="date">July 20, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://community.hpe.com/t5/Grounded-in-the-Cloud/Make-the-right-workload-placement-decisions-in-a-hybrid-IT/ba-p/6971216" ><img src="https://cdn.thenewstack.io/media/2015/01/HP_Helion@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://community.hpe.com/t5/Grounded-in-the-Cloud/Make-the-right-workload-placement-decisions-in-a-hybrid-IT/ba-p/6971216" >Make the right workload placement decisions in a hybrid IT environment</a></div><span class="date">July 20, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.gocd.org/2017/07/20/deployment-pipeline-automated-testing.html" ><img src="https://cdn.thenewstack.io/media/2017/01/056bb160-thoughtworksgocd@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.gocd.org/2017/07/20/deployment-pipeline-automated-testing.html" >Part 2 - Deployment pipeline and types of automated testing: CD 101</a></div><span class="date">July 19, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.twistlock.com/2017/07/19/kubernetes-1-7-security-features-overview/" ><img src="https://cdn.thenewstack.io/media/2017/06/87a847e8-twistlock@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.twistlock.com/2017/07/19/kubernetes-1-7-security-features-overview/" >Kubernetes 1.7: Security Features Overview</a></div><span class="date">July 19, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="http://coreos.com/blog/open-container-initiative-specifications-are-10" ><img src="https://cdn.thenewstack.io/media/2015/04/CoreOS@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="http://coreos.com/blog/open-container-initiative-specifications-are-10" >Open Container Initiative Specifications are 1.0</a></div><span class="date">July 19, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://blog.digitalocean.com/1-million-users/" ><img src="https://cdn.thenewstack.io/media/2014/04/DigitalOcean@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://blog.digitalocean.com/1-million-users/" >Riding the Jet Stream to 1 Million Users</a></div><span class="date">July 18, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.stackrox.com/post/2017/07/introducing-stackrox-a-modern-security-platform-for-the-microservices-age/" ><img src="https://cdn.thenewstack.io/media/2017/07/2b16e98a-stackrox@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.stackrox.com/post/2017/07/introducing-stackrox-a-modern-security-platform-for-the-microservices-age/" >Introducing StackRox: A Modern Security Platform for the Microservices Age</a></div><span class="date">July 17, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="http://blogs.univa.com/2017/07/why-health-care-research-needs-multitenant-orchestration-to-save-lives/" ><img src="https://cdn.thenewstack.io/media/2016/12/436744b5-navops@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="http://blogs.univa.com/2017/07/why-health-care-research-needs-multitenant-orchestration-to-save-lives/" >Why Health Care Research Needs Multitenant Orchestration to Save Lives</a></div><span class="date">July 07, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.packet.net/blog/our-journey-to-zero-failed-installs/" ><img src="https://cdn.thenewstack.io/media/2017/01/1fa1acd2-packet@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.packet.net/blog/our-journey-to-zero-failed-installs/" >Our Journey to Zero Failed Installs</a></div><span class="date">June 21, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.aporeto.com/cloud-native-apps-security-case-coreos-rkt-xen/" ><img src="https://cdn.thenewstack.io/media/2016/10/Aporeto@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.aporeto.com/cloud-native-apps-security-case-coreos-rkt-xen/" >Cloud Native Apps and Security: The Case for CoreOS Rkt and Xen</a></div><span class="date">June 21, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://blog.containership.io/velocity-devops-conference-2017-san-jose" ><img src="https://cdn.thenewstack.io/media/2017/05/4b0ac4d6-containership@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://blog.containership.io/velocity-devops-conference-2017-san-jose" >DevOps & Scalability On The Brain? O'Reilly Velocity Is This Week!</a></div><span class="date">June 19, 2017</span><br /></div></div><div class="rss-unit"><div class="rss-logo"><div class="imagefix" style="float:none;"><a  target="_blank" href="https://www.apcera.com/blog/deploying-aspnet-core-applications-apcera" ><img src="https://cdn.thenewstack.io/media/2015/08/Apcera@2x.png"></a></div></div><div class="rss-title"><div class="title"><a target="_blank" href="https://www.apcera.com/blog/deploying-aspnet-core-applications-apcera" >Deploying ASP.NET Core Applications on Apcera</a></div><span class="date">May 16, 2017</span><br /></div></div></div>				</div>
			</div>
		

<div class="footer-wrap">

	<footer id="colophon" class="site-footer" role="contentinfo">

	    <div id="mainfooter">

			<div class="clearfix">

		        <div class="footercol">
		            <div id="nav_menu-8"><h4>Topic Hubs</h4><div class="menu-topic-hubs-container"><ul id="menu-topic-hubs" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937477"><a href="https://thenewstack.io/tag/architecture/">Architecture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937478"><a href="https://thenewstack.io/tag/data/">Data</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937479"><a href="https://thenewstack.io/tag/development/">Development</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937480"><a href="https://thenewstack.io/tag/diy/">Do-It-Yourself</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937481"><a href="https://thenewstack.io/tag/operations/">Operations</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937482"><a href="https://thenewstack.io/tag/security/">Security</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937483"><a href="https://thenewstack.io/tag/tech-culture/">Tech Culture</a></li>
</ul></div></div>		        </div>

		        <div class="footercol">
		            <div id="nav_menu-9"><h4>Ecosystems</h4><div class="menu-ecosystems-container"><ul id="menu-ecosystems" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937484"><a href="https://thenewstack.io/tag/artificial-intelligence/">AI</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937485"><a href="https://thenewstack.io/tag/cloud/">Cloud</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937486"><a href="https://thenewstack.io/tag/containers/">Containers</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937487"><a href="https://thenewstack.io/tag/kubernetes/">Kubernetes</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937488"><a href="https://thenewstack.io/tag/microservices/">Microservices</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937489"><a href="https://thenewstack.io/tag/node-js/">Node.js</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-1937490"><a href="https://thenewstack.io/tag/serverless/">Serverless</a></li>
</ul></div></div>		        </div>

		        <div class="footercol">
					<div id="nav_menu-10"><h4>Content</h4><div class="menu-sections-container"><ul id="menu-sections" class="menu"><li id="menu-item-1937808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1937808"><a href="https://thenewstack.io/category/analysis/">Analysis</a></li>
<li id="menu-item-2546387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2546387"><a href="https://thenewstack.io/ebooks/">Ebooks</a></li>
<li id="menu-item-880524" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880524"><a href="https://thenewstack.io/events/">Events</a></li>
<li id="menu-item-880407" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880407"><a href="https://thenewstack.io/podcasts/">Podcasts</a></li>
<li id="menu-item-1937809" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1937809"><a href="https://thenewstack.io/category/research/">Research</a></li>
</ul></div></div>		        </div>

		        <div class="footercol">
		            <div id="nav_menu-7"><h4>The New Stack</h4><div class="menu-the-new-stack-container"><ul id="menu-the-new-stack" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-600"><a href="https://thenewstack.io/about-2/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-601"><a href="https://thenewstack.io/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-602"><a href="https://thenewstack.io/sponsors/">Sponsors</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-764345"><a href="https://thenewstack.io/privacy-policy/">Privacy Policy</a></li>
</ul></div></div>		        </div>

			</div>

	    </div>

	    <div class="footer-social-nav">
			<div class="menu-follow-container"><ul id="footer-follow" class="menu"><li class="twitter menu-item menu-item-type-custom menu-item-object-custom menu-item-583"><a target="_blank" href="https://twitter.com/thenewstack">Twitter</a></li>
<li class="facebook menu-item menu-item-type-custom menu-item-object-custom menu-item-584"><a target="_blank" href="https://www.facebook.com/thenewstack">Facebook</a></li>
<li class="youtube menu-item menu-item-type-custom menu-item-object-custom menu-item-224124"><a target="_blank" href="https://www.youtube.com/channel/UCWea_KfCnTMD39uQuA5TKOQ">YouTube</a></li>
<li class="soundcloud menu-item menu-item-type-custom menu-item-object-custom menu-item-880401"><a target="_blank" href="https://soundcloud.com/search?q=the%20new%20stack">Soundcloud</a></li>
<li class="linkedin menu-item menu-item-type-custom menu-item-object-custom menu-item-586"><a target="_blank" href="https://www.linkedin.com/company/6611720">LinkedIn</a></li>
<li class="slideshare menu-item menu-item-type-custom menu-item-object-custom menu-item-880402"><a target="_blank" href="http://www.slideshare.net/TheNewStack">Slideshare</a></li>
<li class="rss menu-item menu-item-type-custom menu-item-object-custom menu-item-1767"><a target="_blank" href="http://thenewstack.io/rss-feeds">RSS</a></li>
</ul></div>	    </div>

	    <!--
	    <div class="footer-nav-horizontal-TNS clearfix">
			<a href="/about">About</a>
			<a href="/contact">Contact</a>
			<a href="/sponsors">Sponsors</a>
			<a href="/privacy-policy">Privacy Policy</a>
	    </div>
	    -->

	    <div class="site-info">
	        <h4>&copy; 2017 The New Stack. All rights reserved.</h4>
	    </div>

	</footer>



	        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'thenewstack';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script type="text/javascript">
    adroll_adv_id = "N5U6YTQS3VHWDAOX4QEAOP";
    adroll_pix_id = "FQK73G2NDFC5TLARVUPP25";
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>


<!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WGF7MX"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WGF7MX');</script>
<!-- End Google Tag Manager -->

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1667886366787627');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1667886366787627&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

<script type="text/javascript">
_linkedin_data_partner_id = "26441";
</script><script type="text/javascript">
(function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})();
</script><link rel='stylesheet' id='frontend-css'  href='https://thenewstack.io/wp-content/plugins/wp-rss-multi-importer/css/frontend.css?ver=4.8' type='text/css' media='all' />
<script type='text/javascript' src='https://checkout.stripe.com/checkout.js'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/js/vendor/parsley.min.js?ver=2.3.7'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/js/vendor/moment.min.js?ver=2.3.7'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/js/vendor/pikaday.min.js?ver=2.3.7'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/js/vendor/pikaday-jquery.min.js?ver=2.3.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sc_coup = {"ajaxurl":"https:\/\/thenewstack.io\/wp-admin\/admin-ajax.php"};
var sc_script = null;
/* ]]> */
</script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/stripe-checkout-pro/assets/js/public-main.min.js?ver=2.3.7'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/themes/thenewstack/js/navigation.js?ver=20120206'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/themes/thenewstack/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/themes/thenewstack/js/equalHeight.js?ver=20120232'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/themes/thenewstack/inc/responsive-tables/responsive-tables.js?ver=20120206'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/themes/thenewstack/js/script.js?ver=4.8'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.min.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.carousel.min.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.swipe.min.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.tile.min.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/libs/cycle2/jquery.cycle2.video.min.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/dark/script.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/templates/thumbnails/script.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/cyclone-slider-2/js/client.js?ver=2.10.0'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://thenewstack.io/wp-content/plugins/wp-rss-multi-importer/scripts/show-excerpt.js?ver=4.8'></script>



	<script>

		(function trackOutbounds() {

			var hitCallbackHandler = function(url,win) {
			    if (win) {
				    window.open(url, win);
			    } else {
		        	window.location.href = url;
		        }
		    };

		    var addEvent = function(el, eventName, handler) {

				if (el.addEventListener) {
					el.addEventListener(eventName, handler);
				} else {
					el.attachEvent('on' + eventName, function(){
						handler.call(el);
				    });
				}
			}

			if (document.getElementsByTagName) {

				var el = document.getElementsByTagName('a');
				var getDomain = document.domain.split('.').reverse()[1] + '.' + document.domain.split('.').reverse()[0];

				// Look thru each a element
				for (var i=0; i < el.length;i++) {

					// Extract it's href attribute
					var href = (typeof(el[i].getAttribute('href')) == 'string' ) ? el[i].getAttribute('href') : '';

					// Query the href for the top level domain (xxxxx.com)
					var myDomain = href.match(getDomain);

					// If link is outbound and is not to this domain
					if ((href.match(/^(https?:|\/\/)/i)  && !myDomain) || href.match(/^mailto\:/i)) {

						// Add an event to click
						addEvent(el[i],'click', function(e) {

							var url = this.getAttribute('href');
							var win = (typeof(this.getAttribute('target')) == 'string') ? this.getAttribute('target') : '';

							var targetURL = document.createElement('a');
							targetURL.href = url;
							//targetURL.protocol; // => "http:"
							//targetURL.hostname; // => "example.com"
							//targetURL.port;     // => "3000"
							//targetURL.pathname; // => "/pathname/"
							//targetURL.search;   // => "?search=test"
							//targetURL.hash;     // => "#hash"
							//targetURL.host;     // => "example.com:3000"

							console.log('Outbound Traffic ' + targetURL.hostname + ' ' + url);

							ga('send', 'event', 'Outbound Traffic', targetURL.hostname, url,
								{ 'hitCallback' : hitCallbackHandler(url,win) },
								{ 'nonInteraction': 1 }
							);

							e.preventDefault();

						});

					}
				}
			}
		})();

		jQuery(document).ready(function($) {

			$('.rss-unit').on('click', function() {

				var url = $(this).children('.rss-title')
						  .children('.title').children('a').attr('href');
				
				ga('send', 'event', 'RSS Outbound Traffic', url);

			});

		});

	</script>

	


<script id="dsq-count-scr" src="//thenewstack.disqus.com/count.js" async></script>

<script type="text/javascript">

	jQuery(document).ready(function($) {
		
		clearInterval(window.showHideComments);
		window.showHideComments = setInterval(function() {
		
			$('.normalstory-box .commentcloud').each(function () {
				
				var commentCountLink = $(this).find('h5 a');
				var storyCommentCount = commentCountLink.html();
				
				if ( storyCommentCount != '+' ) {
					$(this).show();
				}
			
			});
		
		}, 999);
		
		$('.normalstory-box .commentcloud .links a').click(function(event) {
			event.preventDefault();
			window.location = '//' + window.location.hostname + this.pathname + '#disqus_thread';
		});
		
		
		
		$('.postshare .links #showbox').each(function() {
		    if ( $(this).html == '' ) $(this).html = '+';
			$(this).show();
		});
		
		$('.postshare .links #showbox').click(function(event) {
			event.preventDefault();
		});
		
		
		
		function loadDisqusComments() {
		
			$('html, body').stop().animate({
			    scrollLeft : $('.comment-block').offset().left,
			    scrollTop : $('.comment-block').offset().top
			}, 999, function() {
				
				$.ajax ({
			        type : 'GET',
			        url : '//' + disqus_shortname + '.disqus.com/embed.js',
			        dataType : 'script',
			        cache : true
			    });
				
			    $('.showDisqus').fadeOut();
			
			});
		
		}
		
		
		
		/// Auto-show comments if the URL contains '#disqus_thread'
		if( window.location.href.indexOf('#disqus_thread') > -1 ) {
			loadDisqusComments()
		}
		
		
		$('.social-header .commentcloud').on('click', function(event) {
			event.preventDefault();
			loadDisqusComments()
		});
		
		
		$('.social-footer .commentcloud').on('click', function(event) {
			event.preventDefault();
			loadDisqusComments()
		});
		
		
		/// View/Add Comments Button
		$('.showDisqus').on('click', function(event) {
			event.preventDefault();
			loadDisqusComments()
		});
		
		
		$('.postshare .links').click(function(event) {
			event.preventDefault();
			loadDisqusComments()
		});
	
	});

</script>



</div>

</body>
</html>
